Drupal Version:7.59
CiviCRM Version:5.3.1
I am facing an error of incorrect Links in Emails sent via scheduled mailings.
The HTML is

<a href="https://example.com/sites/example2.com/files/abc.pdf">Test</a>

1) When mail is sent manually by selecting Execute Now enter image description here

the links for the pdf works perfectly

2) When it runs via cron the link generated is this /usr/share/nginx/abc/sites/all/modules/civicrm/extern/url.php?u=2937&qid=34399

I need to debug on both #1 and #2, what can be the appropriate files to debug and what can be the process to debug?

I am having a symlink so in
Settings - Upload Directories



Resource URL


  • It appears as though you have link tracking enabled for your mailing - that's the general format that tracked links follow (except of course for being a relative link and not absolute). Are you using Mosaico by chance? Are you using any kind of third party sending tool (e.g., SendGrid, Sparkpost)? – Lesley Carter - BackOffice Oct 2 '18 at 16:43


Check the resource url is set properly. Navigate to CiviCRM >> Administer >> System Settings >> Resource URLS. Click on '?' to see if all the variables have correct values and are pointing to right directories. If not then you may need to update the civicrm.settings.php file for $civicrm_root variable until the you get th variables right in resource url.



| improve this answer | |
  • Hi I am using a symlink , can that be an issue, apart from that , I dont see the resource url to be havng any issue, i have updated my question,kindly have a look at and provide your valuable feedback. – harshal Oct 2 '18 at 17:47
  • I am taking about RESOURCE URL not the directory path. Yes sometimes symlink is problem. Is you resource url have correct path? – Pradeep Nayak Oct 2 '18 at 17:49
  • how can I debug and find the issue ? – harshal Oct 2 '18 at 17:55
  • can you add the resource url variables into your post? – Pradeep Nayak Oct 2 '18 at 17:56
  • Hi i have added resource url variables, kindly have a look at it – harshal Oct 2 '18 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.