3

When attempting to upgrade CiviCRM version 4.7.25 to 5.6.0 I ran into a number of issues. To rule out this is caused by something specifically from 5.6.0 I also tried 5.4.0. Unfortunately, this did not make any difference.

I get the following error when viewing the 'System status' screen:

Warning: Declaration of CRM_Volunteer_Permission::check($permissions) should be compatible with CRM_Core_Permission::check($permissions, $contactId = NULL) in /var/www/html/civicrm_viva_las_vegas_nl/wp-content/uploads/civicrm/ext/org.civicrm.volunteer/CRM/Volunteer/Permission.php on line 151

The screen stays empty for the rest. After clearing the cache, I also get the following error:

Fatal error: Uncaught Error: Call to undefined method CRM_Core_BAO_Address::isSupportedParsingLocale() in /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component/AddressParsing.php:45 Stack trace: #0 /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component.php(54): CRM_Utils_Check_Component_AddressParsing::checkLocaleSupportsAddressParsing() #1 /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check.php(209): CRM_Utils_Check_Component->checkAll() #2 /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check.php(93): CRM_Utils_Check::checkAll() #3 /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/CRM/Core/Page.php(218): CRM_Utils_Check->showPeriodicAlerts() #4 /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/Civi/Angular/Page/Main.php(70): CRM_Core_Page->run() #5 /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugin in /var/www/html/civicrm_viva_las_vegas_nl/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component/AddressParsing.php on line 45

The upgrade process itself seems to run very smoothly, it does not give any errors.

What could cause the above errors?

4

Jack,

There seems to be problem with the extensions you have installed. Try upgrading CiviCRM after disabling all the extensions. Some extension might not be compatible with latest version of CiviCRM. As a best practice we disable all the extension or plugin of CiviCRM and then perform CiviCRM upgrade. Once finished with upgrade we turn on extension or plugin one by one.

HTH

Pradeep

  • 1
    Pradeep is correct. In particular, there's a newer version of CiviVolunteer, since the version that's compatible with CiviCRM 4.7.25 isn't the same as the version that's compatible with 5.6.0. – Jon G - Megaphone Tech Oct 5 '18 at 17:56
  • Thanks Pradeep. It seems org.civicoop.streetformatnl was causing the problem. I disabled the extension for now. Maybe this could be something to add to the upgrade manual for CiviCRM. – Jack Oct 6 '18 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.