1

[I have updated some information following Tamara's answer, but it is still not accessible by anonymous users]

I need people to be able to be able to sign up and pay for membership.

  1. I set up a CiviCRM Membership and a Price Set for the membership
  2. I created a profile (including custom fields) for the membership registration
  3. I ticked the box that says 'Account Creation Required' under WordPress user account registration option for the profile [Update: one of the profile fields is Email (Primary)]
  4. . I've set up a CiviCRM Payment Page for membership fees using above profile. [UPDATE: I set up some Word Replacements, hence Payment page not Contribution page.]
  5. I've checked the permissions for Anonymous Users to create, edit, view profiles.
  6. CiviCRM: Access all custom data fields checked for Anonymous
  7. CiviCRM: access contact reference fields is checked for Anonymous users [Update: I'm using address details from Contacts]
  8. CiviContribute: make online contributions is checked for Anonymous user
  9. [Update] CiviCRM: Profile listings and forms: is checked for Anonymous user
  10. I've created a Wordpress page and used the CiviCRM shortcode to add the payment page

When I access that page logged in, it displays no problem. Logged out, it's coming up with the civiCRM alert 'You do not have permission to access this page.'

When this happened before for another civiCRM profile I set up (with no payment), it was because I had not ticked 'Create' within the civiCRM shortcode options for Profiles; as soon as I did that, anonymous users could you see the page and fill in the form and create an account.

However, with a payment page, I'm not seeing an option for 'Create'.

How do a I set up a page where people can sign up for membership, create an account in Wordpress, and pay the fee all at the same time when not logged in?

Any help much appreciated.

The page in question.

Cheers, Tracy

  • In fact, none of the payment/contribution pages are accessible to anonymous visitors. I tried the link to the 'Help Support CiviCRM!' page, and get the same message " Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. You do not have permission to access this page. Return to home page." – Tracy Shorrock Oct 10 '18 at 0:39
1

Since you have questions regarding the specific steps you took, I copy and paste all of them below and intersperse with my responses (IN BOLD CAPS for clarity):

  1. I set up a CiviCRM Membership and a Price Set for the membership > GOOD
  2. I created a profile (including custom fields) for the membership registration > GOOD
  3. I ticked the box that says 'Account Creation Required' under WordPress user account registration option for the profile > YOU MUST INCLUDE A PRIMARY EMAIL ADDRESS FIELD IN THE PROFILE FOR THIS FEATURE TO FUNCTION PROPERLY
  4. I've set up a CiviCRM Payment Page for membership fees using above profile. > GOOD
  5. I've checked the permissions for Anonymous Users to create, edit, view profiles...> AS INDICATED HERE, YOU ALSO NEED TO ENABLE THE PERMISSION FOR PROFILE LISTINGS AND FORMS ...and Access all custom data fields (Not sure this is necessary?) > YES, THIS TOO IS NECESSARY
  6. CiviCRM: access contact reference fields is checked for Anonymous users > UNLESS YOU ARE USING CONTACT REFERENCE FIELDS IN YOUR PROFILE, THIS IS NOT NECESSARY
  7. CiviCRM: add contributions of type Campaign Contribution is checked for Anonymous users > UNLESS YOU ARE USING THE FINANCIAL TYPE OF CAMPAIGN CONTRIBUTION FOR MEMBERSHIP DUES, THIS IS NOT NECESSARY
  8. CiviContribute: make online contributions is checked for Anonymous user > GOOD
  9. CiviCRM: access Contact Dashboard is checked for Anonymous user (not sure if necessary?) > AS INDICATED HERE, THIS PERMISSION SHOULD NOT BE GIVEN TO ANONYMOUS USER
  10. I've created a Wordpress page and used the CiviCRM shortcode to add the payment page > IF YOU HAVE ALL OF THE REQUIRED FIELDS IN PLACE PERMISSIONS ENABLED AND THIS STILL ISN'T WORKING FOR YOU, PERHAPS YOU SHOULD TRY USING ONE OF THE OTHER OPTIONS FOR LINKING YOUR MEMBERSHIP PAGE TO YOUR WEBSITE AS INDICATED HERE

Hope this helps! Tamar

  • Hi Tamar, thank you for all the information. I have updated the list points on my original post to note your changes. For 5, I have an email (Primary) field set, so that should be OK. For 6, I've left it as I'm using address fields from Contacts. One thing, in your link for Membership setups, it says for Wordpress: Go to Contributions > Manage Contribution Pages, click Links. I don't see Contributions in the top civiCRM, I have Payments, and under that 'create payment pages', etc. Is that not the same as Contribution pages? – Tracy Shorrock Oct 10 '18 at 0:13
  • Sorry, that should have been 3 (re the primary email field). This is the page that goes on about clicking Contributions / Manage Contribution pages, but I only have Payments / Manage Payment pages. docs.civicrm.org/user/en/latest/membership/… – Tracy Shorrock Oct 10 '18 at 0:25
  • I went to Payments / Payment Pages, and copied the Live link. This too is not accessible to anonymous users :( – Tracy Shorrock Oct 10 '18 at 0:34
  • Hi Tracy - yes, payment pages would be the same as contribution pages - it could be that you have a word replacement in place that changes "Contribution" with "Payment" - in any case, did you enable the specific permission of "Profile Listings and Forms" mentioned in number 5? – Tamar Meir - Cividesk Oct 10 '18 at 16:30
  • Hi, yes, I did (no 9 in my list now). I just can't see anything that's preventing the permission issue for payment (contribution) pages. Not even the ones set up with civiCRM when I did the initial installation (I chose to have the sample data installed). I am getting a status error and cron jobs don't appear to be working, but I have done them maunally from the civiCRM Scheduled Jobs dashboard. – Tracy Shorrock Oct 11 '18 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.