2

Via permissions page and system status page.

Warning: Declaration of CRM_Volunteer_Permission::check($permissions) should be compatible with CRM_Core_Permission::check($permissions, $contactId = NULL) in /home/site/public_html/wp-content/uploads/civicrm/ext/org.civicrm.volunteer/CRM/Volunteer/Permission.php on line 0

Civi 5.6 Wordpress 4.9.8

2

CiviVolunteer is not fully tested for 5.x version and might have compatibility issue like you are facing. This issue has been fixed and is probably waiting in PR queue for it to get merged in next release.

You can either download the patch from here or wait for next release.

HTH

Pradeep

  • Thanks Pradeep - oddly enough CiviVolunteer was not giving any errors under 5.6 until we updated our PHP version to 7.1 from 7.0. – themak Oct 9 '18 at 21:35
  • Yes, PHP 7 supports strict rules. If you had turned on strict rules for 5.6 you could have encountered same error. – Pradeep Nayak Oct 9 '18 at 21:39
  • Thanks - I have applied the patch and accepted your answer. – themak Oct 9 '18 at 21:42
  • Glad my answer worked for you....Cheerz! – Pradeep Nayak Oct 9 '18 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.