2

So I installed shoreditch on a drupal 7 civicrm. I can enable on the extensions page but on /civicrm/admin/setting/url?reset=1 I see no option to enable the shoreditch them. I can add the custom-civicrm.css there but not the shoreditch option I see on another (Wordpress) installation. This is on a civicrm 5.6.0. Any thoughts?

2

Frequent reason for that error: Double-check, that your URL resource entries are correct! At best, you should use the URL variables, such as e.g.:

[civicrm.files]/extensions

  • (shame on me) Thank you Detlev for pointing me in that direction – stijn Oct 23 '18 at 4:01
1

In Drupal, install the Shoredich theme extension. Make sure you use the latest one! Check the extension documentation.

Basically in Drupal you choose the Seven theme as the CiviCRM admin theme.

/admin/appearance

Then, back over in CiviCRM in Resource URLs, you set the CSS to use the Shoreditch CSS.

/civicrm/admin/setting/url?reset=1

Should then work as intended.

0

Had that once before, as @Laryn mentioned clearing my caches helped!

  • I cleared drupal cache, cleaned cache on /civicrm/admin/setting/updateConfigBackend?reset=1, I rebuilt the menu on civicrm/menu/rebuild&reset=1, I removed everything from sites/default/files/civicrm/templates_c... no luck – stijn Oct 16 '18 at 7:07
  • It worked for me.....sorry I can not help you. Hope someone else has another idea. – ErikH - CiviCooP Oct 16 '18 at 7:45
  • other people have it working with civicrm 5.6.0? – stijn Oct 16 '18 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.