0

I cannot load CiviCRM 4.6.3 in my WordPress installation. I can login to Wordpress, but when I click on CiviCRM,

  1. The menu is not loaded
  2. the dashboard remains on "Loading…"

When I check the console (F12 in Firefox) I see this error:

L’utilizzo di getAttributeNode() è deprecato. Al suo posto utilizzare getAttribute(). mootools.js:343:0
SyntaxError: expected expression, got '<' admin.php:1:0
SyntaxError: expected expression, got '<' admin.php:1:0

What can I check?

Screenshot of CiviCRM failing to load after WordPress login

  • 1
    There is not enough information here to help. Please edit your question to provide some more information. For instance: When did it last work? Have you made any changes (upgrades, new Wordpress plugins, moved server) since this started happening? – Jon G - Megaphone Tech May 26 '15 at 15:53
  • Thanks for the edit, but you haven't specified whether this is a new installation or something that happened after an upgrade or other change to an existing installation. – choster May 26 '15 at 22:25
2

This sounds like a javascript error on your Wordpress site. These are typically caused by buggy WP plugins. I suggest you disable plugins to identify the problem.

Here are more detailed javascript troubleshooting steps for CiviCRM.

1

I resolved by deleting the contents of the table "civicrm_menu"

1

You may need to rebuild the menus, you can do this by going to http://example.com/wp-admin/admin.php?page=CiviCRM&q=civicrm/menu/rebuild&reset=1

This should rebuild the menus and bring them back. It's easier than truncating the db table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.