1

When using a contribution form in French with the confirmation page enabled, the page redirects to the English confirmation page url instead of the French.

Start here: https://domain.ca/fr/civicrm/contribute/transact?reset=1&id=[cid]

End here: https://domain.ca/en/civicrm/contribute/transact?_qf_Confirm_display=true&qfKey=[key]

If I manually switch to the French url, everything looks OK, but if you hit the CiviCRM 'go back' button, it will take you back but switch to English again.

Similarly, if you attempt to go to the confirmation page but the form doesn't validate, while the URL doesn't change, the contents switch to English - all except for price set options (price set labels and help text are in English though).

This is our set-up:

  • Drupal 7 with language detection based on url language prefix (en, or fr)
  • Multilingual site using CiviCRM 5.6.1 (latest at time of writing)
  • 'Inherit CMS Language' is enabled
  • Default language is en_CA, secondary language is fr_CA

Extension enabled:

  • iATS Payments
  • Summary Fields
  • ExtendedReport
  • CiviDiscount

The bilingual demo site is currently out of date so I've been unable to confirm if this is just us or 5.6.x in general.

1

This was a configuration error on our part. Clean URLs was not fully functional - the language prefix was missing from the beginning of non-clean URLs so the final URLs were resolving to only the default language.

Adding $conf['clean_url'] = 1; to the settings file resolves the issue.

Thank you @bgm for helping with the demo site so that we could narrow this down to an issue with our site specifically.

0

Are you using the Canadian Tax Receipts extension?

If so, can you test this patch: https://github.com/jake-mw/CDNTaxReceipts/pull/86 ?

  • Thanks for your reply, unfortunately no, we are not using this extension on this particular site. – freeform.steph Oct 26 '18 at 21:56
  • I've updated the original post to include the list of enabled extensions – freeform.steph Oct 26 '18 at 22:42
  • I updated our bilingual demo site (demo.symbiotic.coop) to 5.7-rc, but haven't been able to reproduce the issue. – bgm Oct 29 '18 at 12:54
  • Thank you for updating the demo site! I've tried switching to Garland to rule out a theme issue, have tried disabling CiviDiscount, and played around with the Drupal language settings all to no avail. I am quite stumped on this one. – freeform.steph Nov 6 '18 at 4:34
  • Can you try this patch: github.com/civicrm/civicrm-core/pull/13050 ? – bgm Nov 6 '18 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.