4

Drupal 8.6.3, CiviCRM 5.7.0, PHP 7.2.10. Followed the instructions in https://github.com/civicrm/civicrm-drupal-8/blob/master/README.md (skipped "load dummy data" and -b'd "master" instead of the missing 8.x-master). The error comes up after the final instruction, "install CiviCRM Core." I now have composer.phar and seems to be ready to go, but what are the appropriate command line args & working directory given where I'm at? I'd prefer not to have to scratch everything to follow the directions here or here!

1

I asked on Friday in chat.civicrm.org and it sounded like the current state is still like those other instructions you've linked. I wasn't able to get it working with the automated vagrant setup and haven't got around yet to trying those manual instructions with the latest code, but maybe someone else can confirm sooner.

| improve this answer | |
1

In the end I found that:

 composer require civicrm/civicrm-core

seemed to work for me :)

I found it via:

:~/buildkit/build/ptest/sites/default$ composer require civicrm

No composer.json in current directory, do you want to use the one at /home/xxx/buildkit/build/test? [Y,n]? y


  [InvalidArgumentException]       
  Could not find package civicrm.  

  Did you mean one of these?       
      civicrm/cv                   
      civicrm/civix                
      drupal/civimail              
      drupal/civicrm_cron          
      civicrm/civicrm-core         

and saw the civicrm/civicrm-core in the suggestions...

the site broke after it had installed - but this does seem like the right command.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.