0

I'm a newby just getting started and trying to learn how to set up events in Civi (5.6.0), using Wordpress (fresh install tester site).

In manage events, if I am looking at one of my events (which are saved, happy, and do show up via shortcodes on the Wordpress site) if I click 'event links' and then 'event info', I get a 404 error. All the other event links open fine.

The URL it is trying to go to is this: https://[myURL]/civicrm?page=CiviCRM&q=civicrm/event/info&reset=1&id=4

Any idea how to get it to show the event page? Thanks!

  • Do you have a Base Page set in "Administer > System Settings > CMS Database Integration"? And does it exist in your list of Pages? – Christian Wach Nov 16 '18 at 10:17
  • Thanks for asking! NO, that did return the 404 error. I changed the setting and it worked, YAY! Please explain: What does that setting do- does particular content need to be - or not be - on that page or other pages? Or feel free to point me toward documentation on it, I haven't found it – CiviLearner Nov 16 '18 at 18:27
  • The page can be empty but it needs to be there. CiviCRM uses it to display forms on the front-end since the homepage (which CiviCRM used to use once upon a time) may not call the_content(). Lots of discussion here: civicrm.stackexchange.com/search?q=%5Bwordpress%5D+base+page – Christian Wach Nov 17 '18 at 11:30
  • I'm going to add an answer that reflects this solution. – Christian Wach Nov 17 '18 at 11:32
  • Perhaps you can mark my answer as the accepted answer? Will help others. Thanks! – Christian Wach Nov 20 '18 at 13:26
1

You need to create a Base Page (if it doesn't exist) and enter its slug in CiviCRM by going to "Administer > System Settings > CMS Database Integration".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.