2

trying to install the civicrm buildkit using the instructions found here : https://docs.civicrm.org/dev/en/latest/tools/buildkit/

I am on ubuntu 16.04. When I run curl -Ls https://civicrm.org/get-buildkit.sh | bash -s -- --full --dir ~/buildkit I get the error:

 The following packages have unmet dependencies.
 nodejs-legacy : Depends: nodejs (>= 0.6.19~dfsg1-3~) but it is not going to be installed
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My nodejs version is v11.2.0 (I tried to update to fix this issue). I have tried removing it and reinstalling it. I have done a sudo apt autoremove. I'm not sure what else to try here. Any suggestions on how to fix this?

1

The command you're running, on Ubuntu 16.04, attempts to install the nodejs-legacy package. As it says, it can't because it relies on a particular version of nodejs that won't be installed.

So first - this problem should be replicable with a simple sudo apt install nodejs-legacy, which simplifies the variables and takes CiviCRM out of the equation. It's probably even replicable with sudo apt install nodejs.

Second, it sounds like you have something installed - perhaps a newer version of nodejs? - that's preventing an installation of the packaged version of nodejs.

After removing nodejs, try running dpkg -l | grep nodejs and see what, if any packages are installed.

Alternatively, removing --full from your command will disable attempting to autoinstall packages. If your environment is a good one, this should work fine. You can review the packages you need installed in this part of the script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.