1

Joomla 3.9.1 - CiviCRM 5.7.2

Hallo Community,

I wanted to remove the CiviCRM components from a test site. Unfortunately I picked the wrong TAB (Test and live have very similar names) and removed the CiviCRM components from the "life" site.

I already checked the D/B. All tables are still in place.

When I try to reinstall civicrm components from joomla_site_root/tmp/com_civicrm the process seems to start, but followed by a blank page.

Is there any other way to recover CiviCRM without performing a complete backup. My last backup is about two weeks old, but we had a lot of data updates in this time.

Thank you for any hint!

Bert

  • At the testsystem I could remove the components and the civicrm_ tables in the D/B. After this the installation worked as supposed. Could it fail because the tables are still prensent? – samadhi Nov 29 '18 at 17:40
  • Yes the old tables where still in place. I just deleted the _cache table content as suggested. May it work to copy the D/B, remove all civicrm tables, install CiviCRM new and replace the civicrm tables in the new installation with the old tables? – samadhi Dec 1 '18 at 18:35
0

Have you deleted /media/civicrm/templates_c? That's where Civi caches pages and can be a cause of white screen of doom. You could maybe try deleting/moving the entire media/civicrm directory (saving any files or extensions you've uploaded there) before installing. If that still doesn't help maybe try emptying the dbse tables:

civicrm_acl_cache
civicrm_acl_contact_cache
civicrm_cache
civicrm_group_contact_cache

If none of that works - then maybe you could try creating a new install of CiviCRM to a new database (making sure it's the same version as the one you deleted) and then change the dbse settings in

/components/com_civicrm/civicrm.settings.php
/administrator/components/com_civicrm/civicrm.settings.php

to point to your old dbse (and then deleting the templates_c directory again)

  • Thank you so far. I will start tomorrow afternoon followowing you instruction and keep you posted about the results. – samadhi Nov 29 '18 at 22:56
  • I did as suggested templates_c renamed, no succces media/civicrm renamed no success empty data tables, no success civicrm_prevnext_cache was not mentioned Right? Is there an instruction how to install civicrm to a separate databse for joomla, i think the Standard Installation installs to the joomla D/B only? Thank You! – samadhi Nov 30 '18 at 13:52
  • There’s no straightforward way to do it i’m afraid - i’d probably try something like copying the Joomla tables of the dbse to a new dbse, and point joomla’s configuration.php at this. Then delete all traces of of Civi from your web directory (make sure you don’t have a CiviCRM.settings.php sitting in yr root folder or anywhere). Now install Civi afresh.. it shd go into your cloned dbse. If that works then change your settings.php (and joomla’s config.php) files to point to the old dbse. Good luck! – Nic Nov 30 '18 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.