The following links in the CiviCRM admin menu don't work for me:

  • Volunteers > New Volunteer Project
  • Volunteers > Manage Volunteer Projects
  • Volunteers > Search for Volunteer Opportunities

When I navigate to these links the page never loads; the CiviCRM icon just keeps spinning indefinitely as though it's still processing my request.

I reset the paths and cleared the caches but that didn't help. I also don't see any errors in Reports > Recent log messages (Drupal admin UI).

Background info:

These are my settings:

Extensions Directory: [civicrm.files]/ext/

Extension Resource URL: [civicrm.files]/ext/

URL Variables:

[cms.root] https://example.org/

[civicrm.root] https://example.org/sites/all/modules/civicrm/

[civicrm.files] https://example.org/sites/default/files/civicrm/

Path Variables:

[cms.root] /home/example/www/www

[civicrm.root] /home/example/www/www/sites/all/modules/civicrm

[civicrm.files] /home/example/www/www/sites/default/files/civicrm

Location of CiviVolunteer extension: /home/example/www/www/sites/default/files/civicrm/ext/org.civicrm.volunteer

Update: This issue occurs in parallel with another: my CiviCRM system status page is blank. (I realized they were related when both issues disappeared simultaneously, unfortunately temporarily.)

When navigating to any of the above links (CiviVolunteer and system status) my browser console shows the following errors:browser console error

  • Hi Molly, welcome to CiviCRM on StackExchange. This is entirely run by volunteers who will do their best to help. – petednz - fuzion Dec 4 at 4:44
  • 1
    Hi, Molly! Could you clarify a few things? First, is CiviCRM or Drupal (or both) multilingual? I suspect an API request required to render the pages in question is failing. You might find evidence of this in one of the following places: the JavaScript console (directions for accessing this: webmasters.stackexchange.com/questions/8525/…) or your CiviCRM server log (probably the file with the most recent timestamp in /home/example/www/www/sites/default/files/civicrm/ConfigAndLog). Please update your question if anything turns up. – GinkgoFJG Dec 8 at 21:43
  • @GinkgoFJG, thank you! Both my CiviCRM and Drupal are bilingual. Although I hadn't realized I needed to adjust my civicrm.settings.php (as per civicrm.stackexchange.com/a/24944/6666), which I did yesterday. (Later on that day my issues with CiviVolunteer temporarily disappeared, somehow.) Thank you for pointing me in the right direction as to where to find further clues. I've updated my question with the info I found. – Molly Dec 8 at 23:13
  • I found this thread that appeared similar: civicrm.stackexchange.com/a/20640/6666. I tried changing my Image Upload Resource URL to an absolute URL but when I go to Reset Paths, the CiviCRM popup tells me, "WARNING: The setting (imageUploadURL) has been reverted." And I tried disabling the Asset Cache to no avail. I also adjusted file/directory permissions per civicrm.stackexchange.com/a/22940/6666. – Molly Dec 8 at 23:14
up vote 2 down vote accepted

It looks like you have a config mismatch between your CMS and your CRM. The tell is in the CORS error in the screenshot you provided. It looks like your site is serving content at https://www.example.org while CiviCRM has specified a base URL of https://example.org. (Note that one URL includes the "www" subdomain while the other does not.)

These URLs have to match,or you need to configure your server to allow cross-origin resource sharing (CORS).

I would recommend the easiest solution, which is to ensure that CiviCRM serves assets via the same base URL as your CMS. In civicrm.settings.php file:

define('CIVICRM_UF_BASEURL', 'https://www.example.org/');

  • 1
    thank you so very, very much!--this solved my problem – Molly Dec 10 at 16:22

When I had this issue, it was linked to the url paths. I know you said you checked these but I’d double check paths.

  • 1
    Concur, double check your Directories, your Resource URLs, clear caches and maybe rebuild menu too just in case <your_site_name>/civicrm/menu/rebuild (I know you have done some, just rattling off the fuller list) – petednz - fuzion Dec 4 at 4:46
  • Thank you, both, for your very quick and helpful responses. I'm new to both CiviCRM and Drupal so I will investigate how to go about checking my URL paths, Directories and Resource URLs. (In the meantime, if you know of some resources you could point me to to help me figure this out I'd be much obliged!) (Clearing the caches and rebuilding the menu hasn't solved the problem thus far.) Right now my URL paths look like this: www.example.org/civicrm/vol/#/volunteer/manage/0 www.example.org/civicrm/vol/#/volunteer/manage www.example.org/civicrm/vol/#/volunteer/opportunities – Molly Dec 4 at 6:25
  • I've tried the following but without success: -modifying my civicrm.settings.php as advised here: civicrm.stackexchange.com/questions/19495/set-civicrm-files/… -setting my resource URL to https:// example.org/sites/default/files/civicrm/ext/ – Molly Dec 6 at 2:07
  • I've edited my question with my current settings info, in case that helps. – Molly Dec 6 at 3:02

I would check you have the AJAX API permission enabled for your role. That will stop the page working properly.

  • Thanks very much for your suggestion; I already have that permission enabled (as well as complete admin permissions set in Drupal). – Molly Dec 7 at 16:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.