When I try to enter the localization management section, I encounter such an error.

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: insufficient permissions.

We use the newest version of joomla and Civicrm that i downloaded on the offical sites.

Tell me how to solve this problem?

up vote 1 down vote accepted

I would check your MySQL permissions - my guess is that you lack the CREATE VIEW permission, which is necessary for multilingual installs. Here is a full list of MySQL permissions needed.

If you go to CiviCRM's Administer menu » System Settings » Debugging and Error Handling, you can turn on Debugging and Backtrace, which will give you a longer error message detailing exactly which permission is missing. If my answer doesn't fix your problem, please do so, then edit your question to include the additional info.

  • I do not have knowledge of working with mysql tables Could you tell us step by step how can I set permissions in MySQL? But the log, the errors that I received, including the recommended options: yadi.sk/d/caeAFEoq9y2umw – Вася Пупкин Dec 6 at 22:26
  • From your backtrace, the permission that's missing is CREATE TRIGGER. Unfortunately, setting up MySQL permissions is dependent on your host, so I can't give you better advice. However, you can talk to your hosting company and tell them you need CREATE TRIGGER permissions. Be aware that some low-cost hosting companies will not give you this permission. – Jon G - Megaphone Tech Dec 6 at 22:38
  • Thank. Posted in support. – Вася Пупкин Dec 6 at 22:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.