0

enter image description hereenter image description hereenter image description hereFor some reason, cron doesn't work. On CMS joomla The system thinks that it works, and shows in the status that everything is fine, but mailings are not sent at the same time. Cron settings on the screen. Tell me what could be the matter? Cron doesn't work joomla

  • 1
    HAve you tried setting cron up on your server? – Tony Horrocks Dec 11 '18 at 11:58
  • I send screen. This screen cron in my server. – Вася Пупкин Dec 11 '18 at 13:13
  • 1
    When you go to the civicrm cron page does it show that it has run? Go to Administer -> System Settings - > Scheduled Jobs. Does the Last Run datetime reflect when you last expected the cron to have run? Does the View Log indicate success? – Jay Edgar Dec 11 '18 at 15:13
  • Yes. He is run. – Вася Пупкин Dec 11 '18 at 15:28
  • 1
    Your cron appears to be running every minute. What jobs do you have enabled under Scheduled Jobs? – Aidan Dec 11 '18 at 16:15
1

This may be the Joomla-specific bug documented in dev/joomla#6, where cron runs successfully but the mailing scheduler fails due to a permission failure.

0

Mine is working in joomla/civicrm, here is what I use for the cron job: wget -O - -q -t 1 'https://"my domain name"/administrator/components/com_civicrm/civicrm/bin/cron.php?name="my cron user name goes here"&pass="my cron user password goes here"&key="my key goes here"'

The " are there to help identify where you will fill in your specific info.

Make sure your joomla user, that you are using for cron has superuser rights in joomla.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.