I'm using civiCRM 4.6 Wordpress 4.1.5 hosted on Bluehost.

Can you upload images to mailings via image properties>upload>send to server?

This seems to navigate to page that doesn't exist and the image does not get uploaded.

If you go to image properties > browse server it just navigates to this page: http://lmysite/wp-content/plugins/civicrm/civicrm/packages/kcfinder/browse.php?cms=civicrm&type=images&CKEditor=crmUiId_1&CKEditorFuncNum=3&langCode=en and says page not found (with my header and footer).

I think my directories are correct. image upload url: http://mysite/wp-content/plugins/files/civicrm/persist/contribute/

resource URL: http://mysite/wp-content/plugins/civicrm/civicrm/

And my civicrm.settings: $civicrm_root = '/serverpath/public_html/wp-content/plugins/civicrm/civicrm/'; if (!defined('CIVICRM_TEMPLATE_COMPILEDIR')) { define( 'CIVICRM_TEMPLATE_COMPILEDIR', '/serverpath/public_html/wp-content/plugins/files/civicrm/templates_c/' ); }

I don't know if this is also related to another unresolved problem I have to do with mailings: Why do 'track click through' links not redirect to correct address?

This seems to be related but is for Joomla: https://civicrm.org/blogs/kurund/enable-image-uploads-and-server-browsing-for-ckeditor

This is a similar problem but the conclusion is unclear: http://forum.civicrm.org/index.php?topic=30066.0

4 Answers 4


This may have been a bug in 4.6.0. Can you try upgrading to the latest version and see if that fixes it?

  • 1
    Sorry I have been using 4.6.2. Should I upgrade to 4.6.3? Is there a guide on how to upgrade? Commented Jun 9, 2015 at 22:10
  • Yes, please test using the latest available release. Commented Jun 15, 2015 at 23:44
  • Upgrade docs are linked from the page you'll download the new release from. Commented Jun 15, 2015 at 23:44
  • I'm having the same issue using 4.6.5 on D7.
    – Yossi
    Commented Aug 13, 2015 at 20:17

If it said "Cannot find any of the supported PHP image extensions!" or it does not appear sometimes

Try go to php.ini, enable ;extension=php_gd2.dll by removing ";"


Just wanted to note - ran into the same kind of problems. Turns out that for some reason when the civicrm file extracted it didn't add the right account user for the owner of all the files. Fixed that and everything works fine now. Just figured I'd post this in case someone else ran into the same problem. :)


I am having the exact same problem. I upgraded 9 civi sites today and this is the only one that is causing me problems. Checked resources directorys, civi settings file and everything appears to be correct. This was not an issue prior to the upgrade on 4.6.8. Scratching my head.

  • I was having issues so I uploaded an older version of the kcfinder and it works fine
    – Yossi
    Commented Oct 29, 2015 at 21:01
  • Thanks! While your answer didn't solve my problem, it did get me in the right direction. Turns out there were permission issues in my directory structure modules/civicrm/packages/kcfinder - my folders were all 775 instead of 755. Once I made this change up the tree all worked again. Commented Oct 30, 2015 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.