6

I've looked at several previous posts, but it's not clear to me if they relate to the issue I'm experiencing. Just updated to CiviCRM 5.8.1 on Joomla 3.9.1. Currently the HTML editor is missing on mailings and events, it's just a box with the straight HTML. The error console is giving the error id.split is not a function from the angular.js file.

Also missing is the Configure CKEditor button. When I check the demo, I see it there, but it never shows up on our site when CKEditor is selected. I also tried installing and selecting the TinyMCE plugin as the editor, but again that makes no difference in the edit window. I'm getting this error in the Display Preferences page: Empty string passed to getElementById().

I've cleaned the caches and checked that the Resource URLs are correct. Unsure what to troubleshoot next.

  • Same here. Introduced with 5.8 - same with Wordpress. – themak Dec 18 '18 at 2:09
4

There appears to be a recent bug, possibly introduced in 5.8 though I'm not certain, that affects the CKEditor, namely missing Configure CKEditor button and CKEditor itself won't appear. See this issue: https://lab.civicrm.org/dev/core/issues/594#note_11806

If you are comfortable working in the database directly you can work around this by deleting the existing setting for WYSIWYG editor and then avoid saving Display Preferences until this is resolved. DELETE FROM civicrm_setting WHERE name = 'editor_id';

This bug is now resolved in CiviCRM 5.9. After installing the 5.9 update save the Display Preferences & CKEditor settings as per the post-install notice.

  • 2
    Thanks for the answer. I checked out the issue and dropped the table row; now it's working as expected. – LMK Web Dec 18 '18 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.