2

Seasons greetings I am using conditionals to hide content on a civicrm webform using Drupal 7 with Civicrm 5.8.2. It has been working fine, but the form now presents with all the conditional fields displayed. This does work correctly, if the user is logged in. That is not acceptable as all users are anonymous. My test system using the same versions is working correctly. I have ensured that all versions are the same across the two systems. Any clues on where to look now would be much appreciated. Regards Graham

  • Have you compared the permissions settings between your live site and the test system? – Lesley Carter - BackOffice Dec 27 '18 at 16:24
  • Lesley Thank you. Yes I have and they are identical. – gcpower Dec 27 '18 at 22:11
2

webform conditionals is native to D7 webform module - and independent of webform civicrm module.

If conditionals for D7 webform module are not working as expected you may have some javascript issues on your site. Look in the browser's console to check for errors.

If your test system is using a different front end theme and if admins with permissions are able to use admin theme - then it's very likely that your javascript issues are inadvertently caused by your front end theme. Perhaps it requires jquery update module e.g.?

  • Karin Thanks for your suggestions. Both sites use Bartik and Seven for Admin. There are the same versions. The browser console shows fourteen errors in the main system and none in test. They all start with Uncaught TypeError: Cannot read property – gcpower Dec 27 '18 at 22:31
  • I have installed the jquery update module and the version is set to 1.10. The status page confirms this. Errors now reduced to five, but the conditionals still not working. – gcpower Dec 27 '18 at 22:45
  • I have checked whilst logged in and conditionals not working now.. – gcpower Dec 27 '18 at 22:48
  • Check everything (modules, versions, config) across test and production - there has to be a difference. – KarinG - Semper IT Dec 28 '18 at 1:05
  • Since installing the jquery update module, the module listing order has changed. It also means that the drop downs are no longer active, preventing me from checking version numbers. Other than the jQuery module, the module list is the same. The two config files are identical. – gcpower Dec 29 '18 at 8:30
1

Matthew Wire has solved this for me. It was a jquery error. It seems to happen if the new CiviCRM menu (kam extension) is enabled - so must be some interaction going on with loading CiviCRM resources. Disabling that seems to resolve the javascript issues and hence webform starts working again.

  • does this mean a fix is needed for kam or for webform and are you or matt following up on this? – petednz - fuzion Jan 6 at 22:23
  • I'm not quite sure what is actually causing the error (which is a browser console function undefined error) (other than I assume that some resources being loaded for kam are overriding resources used by webform). The difference in this case was that the dev site did not have the kam extension installed - and I haven't tried installing it. @gcpower perhaps you could try installing the kam extension on your dev site and if it's an issue there report it as an issue at github.com/aydun/uk.squiffle.kam – Matthew Wire Jan 9 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.