1

I have been trying to discern if issues I have been experiencing since a recent upgrade to 4.5.8 are actually a bug. We use Wordpress.

Basically I've discovered that our many, many message templates, which all used to have a default PDF Page Format set, seem to struggle to retain their assigned default. Additionally, when you are in the process of generating a letter against a contact, and you try to override the default Page Format settings in the 'accordion' section, the margin values etc are not overwritten when you make a new selection.

I have tried to replicate the issue on the up-to-date test site, but it seems I can't get access to the message templates section so it is impossible to tell. I've had a good search and no-one else seems to have reported this. Has anyone else noticed issues here?

Thanks

  • Yes, I've seen this since upgrading from 4.4.x to 4.5.8. Switching templates fails to update the formats reliably, and I'm fairly sure the formats can actually get overwritten when the template is used in some circumstances - which would explain your issue with them retaining the assigned defaults. Thought it might be one of our extensions, but if you're seeing it too I'd guess it's more likely core. I had a crack at fixing it, but couldn't tease apart the scenarios to create a decent bug report - then ran out of time. Sorry this isn't very helpful! Am happy to test and verify if you want to – Andrew West May 28 '15 at 11:33
  • Looks like this has been fixed in 4.6.4: issues.civicrm.org/jira/browse/CRM-16661 – Andrew West Jun 18 '15 at 10:49
  • Excellent. Olly, who reported this as a bug on the jira site, is acting as our consultant at the mo. I asked him to put it up there, but amazed at how quickly it's all wrapped up. K – Kester Muller Jun 19 '15 at 12:46
1

I did try creating an example against http://wp45.demo.civicrm.org/ - It worked fine. Even I have worked in previous version (4.4). I haven’t got any issue at all. So, please try setting the table width = 100% - this should work correctly.

Example: from Demo (used message template: “Sample CivicMail Newsletter Template”).

Had a table setting like below table bgcolor="#ffffff" cellpadding="0" cellspacing="0" width="612"

Just change the above line to table bgcolor="#ffffff" cellpadding="0" cellspacing="0" width="100%"

This gave me a correct output – with proper margin – I guess this Helps!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.