2

If I send a confirmation receipt (checked 'Send Confirmation and Receipt?' during renewal of a membership), the sender address is wrong if the preferred is chosen. In stead of displaying the address given, it scrambles the address to 'id of the address in civicrm_mail table'@'server host name', e.g. 2@s2.domain.tld.

When I choose another address, the sender address is fine.

  • Can you give more details so folks can help? CiviCRM version and outgoing mail settings would be helpful here. – Jon G - Megaphone Tech Jan 4 at 1:22
  • Thanks, Jon. Version is 5.8.2. Components: CiviMember, CiviReport, CiviRules (not using CiviMail). Outgoing e-mail: 'Allow Mail to be sent from logged in contact's email address' checked. Mail system: mail(). – Webmaster COVS Jan 5 at 15:04
  • Tested it with 5.9.0. as well. – Webmaster COVS Jan 5 at 15:33
2

It looks like you've discovered a bug! I'm sorry this happened to you, but identifying this helps to make the software better.

I confirmed this bug, and also confirmed that it's not limited to the mail() setting. I've opened an issue on the CiviCRM issue tracker.

UPDATE: I decided to dig into this a little bit to see if the fix was easy, and it wasn't too bad. It's available for review now. If you could apply the fix and let folks know on Github how it works for you, that would be great! If you're not sure how to apply the fix, get in touch with me on https://chat.civicrm.org, my name there is @junglebird.

  • Thanks for your quick fix. I have succesfully applied the patches: the email adddresses are now what they are supposed to be. – Webmaster COVS Jan 6 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.