2

CiviCRM 5.8.2 / Drupal

I have defined a Smart Group based upon a custom field (recipient) = 1, to be used as a smart mailing list.

(I use VBO to set this field to 1 for my selected recipients, and this works OK : checked in the custom field table).

But to have my Smart Group updated, I have to wait 5 minutes (possibly less), + there is no completion signal, so, my users will not accept it.

I have tested several processes to try to force the update, among which :

  • /civicrm/group?reset=1&update_smart_groups=1
  • /civicrm/group?reset=1

But they give erratic results : only some recipients are included in the Group, while others are not.

The tricky thing is that, if I click to change the Smart Group Criteria, the recipients list displayed is correct.

Clearing the cache appears to be a possible solution, but it is an admin reserved feature.

Any help is welcome.

  • Have you changed the smart group timeout parameter? I usually set this to 1 – Andy Clark Jan 4 at 17:23
  • I know I can do that, but I don't want my users to need a chronometer (there is no completion signal) ... and even 1 mn wait is long. I would like that my users be able to update the Smart Group at the time they need it, even "manually". – Jacques-Marie Moranne Jan 5 at 10:23
  • Set the timeout to 0 – jackrabbithanna Jan 8 at 12:40
  • Thank you Jack ; though it does not seem recommended, I will test that – Jacques-Marie Moranne Jan 10 at 11:17
  • I just tested this solution (timeout = 0) : it works fine if I wait some time for the Smart Group to update : but if I open the Smart Group too quickly, I have some missing members ; my mroblem is that I don't know how much time I have to wait, since I have no completion signal. Blindly, I specified 20 seconds. But I am not quite satisfied. – Jacques-Marie Moranne Jan 10 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.