2

I have installed Joomla on CentOS 7, and then CiviCRM 5.9 on top of that. If I install a CRM dashboard menu I get an error message "Requested page can't be found". (I tried logging on to Joomla as the administrator, but the error still occurs. Do I need to create / log in as a different user?)

Additional error message text is as follows: ' @import url(/joomla/components/com_civicrm/civicrm/css/civicrm.css); @import url(/joomla/components/com_civicrm/civicrm/css/crm-i.css); @import url(/joomla/components/com_civicrm/civicrm/bower_components/font-awesome/css/font-awesome.min.css); Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. You do not have permission to access this page.

Return to home page.

function toggle( element ) { var parent = element.parentNode; var className = parent.className; if ( className == 'crm-accordion-wrapper collapsed crm-fatal-error-details-block') { parent.className = 'crm-accordion-wrapper crm-fatal-error-details-block'; } else { parent.className = 'crm-accordion-wrapper collapsed crm-fatal-error-details-block'; } } '

From what I can see, the addition of the CRM dashboard menu should have worked straight out of the box. Am I missing something here?

Any advice would be most appreciated.

  • Hugh, have you been able to make any progress with this? It would help the wider community if you could report back. – Andrew Thompson Jan 18 at 1:50
4

You are right that it should work out-of-the box. This might not be the full solution, but your error is showing that the URLs are missing /administrator (that is, /joomla/components/com_civicrm/civicrm should be /joomla/administrator/components/com_civicrm/civicrm) so I think you are affected by this issue: https://lab.civicrm.org/dev/joomla/issues/5

Try changing 'CiviCRM Resource URL' (in Administer > System Settings > Resource URLs) from [civicrm.root] to administrator/components/com_civicrm/civicrm/.

I suspect there will still be something else to solve but try that to begin with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.