2

Wordpress 5.0.3

CiviCRM 5.9.0

I'm looking at the help pop-ups compared on two pages. (The text in the black box in the two images)

I've got Path Variables on the Upload Directories page: Path Variables - Upload Directories Page

I've got URL Variables on the Resource URLs Page: URL Variables - Resource URLs page

They are supposed to be the same variables: [cms.root], [civicrm.root] and [civicrm.files], yet on the former page, the variables have no slashes. On the latter page, they do have slashes. I suspect the one without slashes is correct, because the Extensions Directory for both uses [civicrm.files]/ext/ and had already been set that way.

Before I make any mistakes, these are the settings I have on Resource URLs now:

CiviCRM Resource URL: wp-content/plugins/civicrm/civicrm/

Image Upload URL: wp-content/plugins/files/civicrm/persist/contribute/

These are what I should probably change them to:

CiviCRM Resource URL: [civicrm.root]/

Image Upload URL: [civicrm.files]/persist/contribute/

Please confirm.

Is it possible this a minor bug?

4

Its not a bug, adding extra '/' won't make any difference. The variables shown Directories and Resource URL forms have same naming conventions however they are rendered in different way for each form.

CiviCRM Resource URL: [civicrm.root]/

Image Upload URL: [civicrm.files]/persist/contribute/

Your Settings looks fine.

Cheers

Pradeep

  • Thank you so much. So you're saying that CiviCRM has a routine that checks for both cases and renders accordingly, correct? But still, wouldn't it be more logical if [cms.root] and the other variables were listed identically across the interface for consistency's sake? – Chris Jan 16 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.