I've uploaded the file civicrm-5.8.2-wordpress.zip into the plugins folder and unzipped it. I've activated the plugin. The first time through this process the installer ran to the point of creating the database, but then this error shows up on the CiviCRM dashboard:

"Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Constraint Violation - contact_id should possibly be marked as mandatory for DashboardContact,create API. If so, please raise a bug report."

I deactivated and uninstalled the plugin, unzipped it again and activated it. Same error. And the Settings menu does not show a CiviCRM Installer.

CiviCRM shows up in the left nav menu of WP, but clicking on it gives the same error above.

Any guidance would be much appreciated!

1 Answer 1


I realize your situation isn't identical the one discussed here but I would try running the upgrade script to see if it resolves your issue.

If not - one important change is to make sure you remove the CiviCRM database tables when reinstalling! If you installed to a separate database from WordPress, that should be easy. If not, and it's not practical to restore from a backup, you can drop all tables with a prefix of CiviCRM.

  • Also, come to chat.civicrm.org, folks are very helpful generally and are willing to go the extra step for a newcomer to the community! Jan 18, 2019 at 22:09
  • Thanks. I ended up wiping the whole site and reinstalling. Not elegant, but I was just in the early stages, without much data in WP yet, so it was fine. Jan 29, 2019 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.