6

In our Joomla 3.4.1/CiviCRM 4.6.3 setup, we heavily depend on setting up households and linking people to them. For instance, if you become a contributor, the entire family is entitled to discounts, so we link the contribution to the household rather than individual people. Furthermore it helps us with duplicate entry of address information for people of the same household.

The situation is so that we create a household, then create contacts and link the contacts to the household using the "Use another contact's address" feature.

Recently however, after having done our initial data-entry and linking contacts to households in the above manner, I noticed that I could no longer edit most of my contact's information once their address was linked to another one.

In order to test this, I logged onto the demo site and created a fresh household and a contact. Set the contact's (home) address to that of the household using the "Use another contact's address" option and saved the contact. Next I tried to edit the contact (using the 'Edit' button) and tried to enter an external ID. Upon clicking 'Save', CiviCRM says it has updated the contact, but in fact no change is visible. I currently employ one of two workarounds: 1) For fields where it is possible to get an in place 'Ajax' edit-field, I use those because when I use that the change does get saved. 2) I temporarily uncheck 'Use another contact's address', make all my changes and save, go to Edit again and re-check (and select) the household address.

Of course, workaround 2 is kind of cumbersome, but unfortunately the only solution for fields that don't have an Ajax-type edit option such as External ID and contact photo.

Considering that the demo site behaves the same as my own installation, I'm inclined to submit a but-report to the Jira-tracker, but I would like to know if anyone else is seeing this same issue.

  • I haven't had that exact scenario, but if the demo site behaves that way as well, I'd agree that submitting a bug report on JIRA is the way to go. – Laryn - CEDC.org May 30 '15 at 13:47
  • 1
    A JIRA-issue was opened and has been confirmed by development and assigned. – Maurice May 31 '15 at 23:45
2

This has been confirmed as bug CRM-16588. Please consider marking this as the accepted answer, so that future Stack Exchange users with this issue can find the bug status to identify when the bug has been fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.