2

CiviCRM was working fine until I downloaded an extension called CiviRules. I looked into the API for field UFMatch, clicked around in there, and pressed execute (got no warning that it was going to change anything in the database, so I just assumed that it was running a test) and it resulted in no errors supposedly.

I also can't delete the extension, it sends me to an HTTP 500 error. Whenever I input a string search, it gives me a drop menu of contacts with matching strings but when I want to get a list of all the contacts in the database, it takes me to the WSOD!

What can I do to try and fix this?

Edit: it looks like any time I search for something (e.g. contributions, events, participants, contacts etc.), it takes me to the WSOD.

Edit 2: I'm using CiviCRM 4.6.37 and Drupal 7.59. And I'm not sure if it was actually CiviRules or clicking something in the API Explorer... I downloaded CiviRules extension first before I played around with API Explorer. My reasoning for poking around API was to see if there was some way to link/unlink user IDs with CiviCRM contacts and reuse a general username/account for changing members. Hopefully that makes sense! :-/

Edit 3: Problem is fixed. IT support at my organization’s end conquered the WSOD. Lesson learned: don’t mess with API if you don’t know what you’re doing. ¯_(ツ)_/¯

Thank you all for your responses!

bumped to the homepage by Community 15 mins ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • It's unclear from your wording whether CiviRules is the problem, or clicking something in the API (API Explorer?) caused it. Could you please edit to say a bit more? – Jon G - Megaphone Tech Jan 24 at 4:17
  • Also, please add your CiviCRM version and your CMS (Drupal, WordPress, etc.)? Thanks! – Jon G - Megaphone Tech Jan 24 at 4:20
  • I'm using CiviCRM 4.6.37 and Drupal 7.59. And I'm not sure if it was actually CiviRules or clicking something in the API Explorer... I downloaded CiviRules extension first, if that helps. – Janine Jan 24 at 4:27
  • What exactly did you execute in the api explorer? It looks to me like you may have altered or deleted a UFMatch record? – Coleman Jan 24 at 14:20
0

I don't have any experience with CiviRules specifically, but the two things that usually clear up WSOD for me (on WordPress at any rate -- what CMS are you using?) are to clear out wp-content/uploads/civicrm/templates_c, or you can also try going to Administer -> System Settings -> Cleanup Caches and Update Paths, then click the Cleanup Caches button.

Depending on what version of everything you're on there's also the possibility that the CiviRules extension isn't compatible with your version of CiviCRM, although a quick glance at their releases seems to indicate they keep very on top of things.

It'd also be helpful to see the log details about the 500 error if trying the things above doesn't resolve the issue.

Hope that gives you some things to go on.

  • !Pic of one of the warnings I get. I also tried clearing the cache but it took me to the WSOD as well. The rest of the site seems to be working except for the search function and executing certain tasks like trying to delete the CiviRules extension or clearing cache. – Janine Jan 24 at 4:18
0

Are you able to reinstall from backup? I’m wondering if by using the API Explorer you may have accidentally changed things best left unchanged.

  • Hmm, not too sure. Do you know if backups are generated automatically? Would it restore a fairly recent backup? Or... are backups essentially customised by the user? – Janine Jan 24 at 5:15
  • Some service providers will make backups for you - but you would know if you had one. See Coleman’s note above -> try remember what you tried to do in the API explorer – KarinG - Semper IT Jan 24 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.