1

I'm sure I'm missing something basic, but following the various documentation and examples I've seen I can't get {$contribution_aggregate} to actually output the aggregate contributions for a donor, it just outputs literally that text.

Steps I'm taking:

  1. Find contributions, select the ones I want to include in a thank you letter
  2. Select "Thank You Letters - print or email"
  3. Select Group contributions by contact
  4. Separator: Vertical table cell
  5. Print and email options: Generate PDFs for printing (just don't want to email until it's correct of course)
  6. Document body: to test I'm literally just putting {$contribution_aggregate} in the body
  7. Click "Make Thank-you Letters"

And the resultant PDF literally just has {$contribution_aggreate} in it.

I'm on CiviCRM 5.9.0 on WordPress 5.0.3.

Thanks for any guidance anyone can provide!

3

Look in your civicrm.settings.php (in wp-content/uploads/civicrm). There's a line that says:

define( 'CIVICRM_MAIL_SMARTY', 0 );

Change it to

define( 'CIVICRM_MAIL_SMARTY', 1 );

See https://docs.civicrm.org/user/en/latest/common-workflows/tokens-and-mail-merge/#smarty

  • D'oh! Thank you so much. Overlooked that clearly very important tidbit. Looks great now! Thanks again. – Matt Woodward Jan 24 at 2:41
  • Great! . . . . . . . . – Demerit Jan 24 at 2:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.