-1

I am using CiviCRM integrated with Drupal 7. Hosting is in pantheon server. I followed the CiviCRM document.

https://docs.civicrm.org/sysadmin/en/latest/upgrade/drupal7/

According to this, put the site in maintains mode. Deleted the old CiviCRM folder. Uploaded the new CiviCRM folder. Run the http://test-hgs-emun.pantheonsite.io/civicrm/upgrade?reset=1,

After some time, The application did not respond in time. error is coming

I thought some file is taking more time to execute. so contacted pantheon server support team. But Pantheon support team telling they don't increase the execution time more than 120 sec.

I am stuck in a middle please tell me what to do? to solve this.

  • 1
    Please tell me you did a backup before you started? What I would do is restore the backup and then do an interim upgrade to say 5.0 - in other words treat it gently. If that is successful, then go for 5.9. Backup each time. I tried doing this upgrade yesterday and it froze on me as well. – Tony Horrocks Jan 24 at 14:01
  • @TonyHorrocks you are suggesting to one by one version upgrade right?. I mean 4.7 to 4.8 after that 4.9 like this till 5.9. If so it will take to much time. currently, I am in CiviCRM 4.7 – sharaths Jan 25 at 10:02
  • WHen I got stuck (I was on 5.6) I restored everything and then went to a 5.7 upgrade. That worked fine. I then went to 5.8 and then 5.9.1. Im not suggesting you do that all the way from 4.7 I think just at least get one successful minor upgrade and see how it goes. Anyways that worked for me. Good luck – Tony Horrocks Jan 25 at 11:43
  • Make sure to turn off drupal logging, because when any error/notice occurs which are likely to occur during upgrade script is running, that might terminate upgrade script json and will display error in browser's console. So i would say restore from backup, turn off drupal logging and try again. Also according to upgrade process document you need to clear template_c directory too. Hope it helps – Hassan Farooq Jan 29 at 0:31
  • Clearing the template_c folder before the Upgrading worked for me. But I didn't get the reason for a timeout. Anyhow thanks for both of you. – sharaths Jan 29 at 10:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.