4

I just recently upgraded to Civicrm 5.9.1. I had used the Mailchimp extension in the past in test mode previous to our current Civicrm upgrades, and now want to implement it. I was behaving weirdly after the upgrade, so I uninstalled it and then reinstalled it.

I have the newest 2.0.1 version installed, the permissions should be correct since I've assigned all user roles to the Mailchimp: allow webhook posts, and I've verified the webhook is running (doing a Mailings -> Mailchimp settings -> Save and Test responds that the API is returning the correct information from Mailchimp). We're still running Wordpress 4.9.9.

When I attempt a manual sync in one of the Mailchimp sync choices under Mailings, I get a description screen, but no ability to do anything. Has anyone else seen this behaviour or have insights?

There's nothing in error logs that indicate anything is happening with PHP. We're running PHP 7.1.26.

enter image description here

  • any javascript errors in the console? – ericG Jan 25 at 0:12
  • Only thing in the console is: JQMIGRATE: Migrate is installed, version 1.4.1 [Violation] Forced reflow while executing JavaScript took 75ms – Rachelle Niemela Jan 27 at 21:23
  • Can you please see if you can replicate this issue on dmaster.demo.civicrm.org – Hassan Farooq Jan 29 at 0:18
  • I'm getting back to this if possible - gave up in January and moved onto other things. Hassan, the link you provided is not for Wordpress, so I used the Wordpress demo site instead. I got the same results there. It looks like this plugin is definitely broken with the newer versions of Wordpress. That's too bad, because now I've got to do manual updates whenever anyone adds a new contact that needs to also be in Mailchimp. – Rachelle Niemela Apr 6 at 18:48
  • This is in the error log: PHP Warning: Declaration of CRM Mailchimp Permission::check($permissions) should be compatible with CRM_Core Permission::check($permissions, $contactId = NULL) in /home/sxxxx/public_html/wp-content/uploads/civicrm/ext/uk.co.vedaconsulting.mailchimp/CRM/Mailchimp/Permission.php on line 40 BTW, I've checked all roles for permissions, not only anonymous, but still no correct display – Rachelle Niemela Apr 6 at 19:12
1

I did the change suggested here to get rid of the php problems and then reset everything and that seems to have solved the problem. Not sure what was happening, but at least things are working now. mailchimp extension error, php 7.1, civi 5.10.4, drupal 7.x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.