I am having issues when working with Custom fields, that the CRM gets frozen, and have to restart everything. Today I noticed that the MySQL table log_civicrm_custom_field has nearly 140K rows, while I have less than 400 custom fields only. There are hundreds of duplicated rows for each of the custom field, with the same id repeated but different log_date and log_conn_id. Is it natural to have this many log records, can we disable this logging? Or is there a way to clear some of these rows, so that the CRM works faster.

  • See also civicrm.stackexchange.com/questions/25318/large-civicrm-logs. Not sure if it's an exact duplicate question but is similar.
    – Demerit
    Commented Jan 25, 2019 at 13:53
  • I am also running into a similar issue where the screen freezes, the cursor keeps rotating and the data won't save when unpublishing an event, editing activities, and disabling relationships on v 5.10.3. Does anyone have an explanation/solution?
    – Rdarris
    Commented Mar 12, 2019 at 18:59
  • Hi Rdarris, you've posted this as an answer, but this looks more like a question. You are more likely to get a response if you ask a new question. Commented Mar 12, 2019 at 22:30
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review
    – themak
    Commented Mar 28, 2019 at 20:43

1 Answer 1


It might well be natural to have that many log records as they reflect changes that have been made to the fields. So if a field gets a new label or a new option, that would be reflected in the log tables.

You can disable the overall logging (Administer>System Settings>Misc) if you do not need it. It is not required to make CiviCRM run.

You can also elect to keep logging switched on but empty the logging tables regularly? You have to do that in the database, there is no user interface to empty the logging tables.

It could well be however that you switch off logging and your problem persists because that is not the root of the problem? I have so far not experienced the size of the logging tables leading to this behaviour, even with millions of records in it.

  • The issue was not due to the log table, as it still appears even after the log table is cleared. The issue happens when I try to create a new Custom field this way - I gave "alpha numeric" in the first drop down and "select" in the second dropdown under "Data and Input Field Type". Then I scrolled down and checked the "Is this field Searchable" checkbox. Then Save the field and the screen gets freeze (the cursor keeps rotating and it wont save the data). Now the database gets corrupted and I get an error when I open any contact. This happens only if the "Is this field Searchable" is checked.
    – R John
    Commented Jan 25, 2019 at 17:25
  • @RJohn what version of Civi are you using?
    – Aidan
    Commented Jan 25, 2019 at 17:48
  • @Aidan The version is CiviCRM 5.6.0.
    – R John
    Commented Jan 26, 2019 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.