1

I've saved outbound email settings with:

Using sendmail Path: /usr/sbin/sendmail Arguments: -t -i

When I press "Save and send testing email", I can receive testing email correctly from sendmail.

But When I send email with CiviEmail, both testing and batch sendings, Outbound email settings seems to be ignored.

It had worked correctly CiviCRM 4.6, but suddenly broken after I upgraded CiviCRM to 5.9.1.

I noticed this issue, because I am doing relay_host settings with sendmail. It worked on 4.6, but after I upgraded, it doesn't.

Any suggestions?

Here is my sendmail setting. It is working, but when I use CiviEmail it seems not to be used.

relayhost = [domain.for.send]:25 smtp_use_tls = yes smtp_sasl_auth_enable = yes smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd smtp_sasl_tls_security_options = noanonymous smtp_sasl_mechanism_filter = login smtp_sasl_type = cyrus smtp_tls_security_level = verify smtp_tls_CApath = /etc/pki/tls/certs/ca-bundle.crt smtp_fallback_relay = [localhost]

  • I found this is caused by that "From" email field has changed to like b.9271.665034.a72ea4b63703832c@[mydomain] from my specified from email. Even if I specify -f arguments with sendmail on both /etc/php.ini and Outbound email settings, it doesn't affected. I will appreciate any suggestions and comments. my CiviCRM VERP setting is off. – Mickel Jan 27 at 1:28
1

I solved this issue. This is caused by Civimail script automatically append -f[Return-Path] params when it sends any email.

I fixed CiviCRM core code

packages/Mail/mail.php and packages/Mail/sendmail.php

to prevent that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.