3

I'm running the latest version on WordPress. When I tried several times to add a grant, the following error showed:

CRM_Core_Exception: Invalid Entity Filter in /public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/BAO/CustomGroup.php on line 485

I did add a few grant types and disabled the originally installed ones. Could that be the issue?

Thanks!

1
  • OK, I changed the values of the "grant types" from texts to numbers and the error finally went away. I'm able to use texts as values on other dropdown fields such as Contacts, just not for grant types, apparently.
    – j007w
    Feb 4, 2019 at 19:27

1 Answer 1

3

I had this issue just now as well, the full error was:

CRM_Core_Exception: Invalid Entity Filter in CRM_Core_BAO_CustomGroup::validateSubTypeByEntity() (line 651 of /var/www/html/sites/all/modules/civicrm/CRM/Core/BAO/CustomGroup.php).

If you look at the code, you can see that subtypes of entities have to be integers (with the exception of contacts, which appear to have been grandfathered in).

What that means is that when you create a new grant type, you can choose the label and the description, but you shouldn't override the "value" field, which will get auto-populated as the next available integer (for that 'option group'). Or, if you do, you can only choose a numeric value.

Or at least, you have to follow this rule if you want to create custom field groups which are restricted to these grant types. And you probably want to do it anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.