0

I've made civicrm (5.9.1) in a Joomla 3.9.2 installation. Only the English language is available, I find nowhere as I can change the language in German. Do you have a tip for me? Greetings Michael

3

Michael, Welcome to Stackexchange. The language will be available if you have downloaded and place l10n folder in civicrm.

To configure CiviCRM to use an existing translation:

  1. Download the translations distribution - civicrm--l10n.tar.gz - from the CiviCRM Sourceforge downloads site. This tarball contains all files for the latest available translations.
  2. Uncompress the tarball and you will see a directory called civicrm, containing two subdirectories called l10n and sql. The l10n directory contains a set of sub-directories named using their locale codes. (Example: the Canadian French translation files will located in /civicrm/l10n/fr_CA)
  3. Copy this l10n directory, together with all its subdirectories into your CiviCRM codebase root directory. (note if creating the l10n folder manually it should be ell-ten-n, not capital-I-ten-n)

For Joomla this would be site_root/administrator/components/com_civicrm/civicrm. So if you wanted the en_GB language it would look like this

site_root/administrator/components/com_civicrm/civicrm/l10n/en_GB/

For Drupal this would be site_root/modules/civicrm. So if you wanted the en_GB language it would look like this site_root/modules/civicrm/l10n/en_GB/

  1. Login to CiviCRM (as a user with "administer CiviCRM permissions").
  2. Go to Administer » Localization » Languages, Currency, Location
  3. You should now be able to see and select all the localization options in the Default Language and drop-down menu. If you don't, and instead can just see the default 'English (United States)' option, check the preceding steps as the drop-down options are set by the directories under your l10n directory. Also be sure to confirm that the l10n directory is correctly named as l10n (that is: el-ten-en and not eye-ten-en).

Cheers

Pradeep

  • it's so easy when you know where ... I thank you for the quick help! Greetings Michael – Michael Lieder Feb 4 at 21:36
  • @michael can you please mark this post as answered if it solves your problem so that it will be helpful for others. – Pradeep Nayak Feb 4 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.