5

I have configured Amazon SES with CiviCRM, after configure outbond setting in CiviCRM I got mail from my CRM via amazonses.com with Subject "Test for SMTP settings" and body "SMTP settings are correct.". But if I try to send a email campaign I'm not getting any mails from my CRM, and the Amazon console is also not showing any mail details.

I have followed the documentation below.

documentation URL : https://hq.palantetech.coop/projects/commons/wiki/Amazon_SES_for_CiviCRM

I have used SMTP direct from CiviCRM.

  • Hi - I wrote those instructions, so I have two questions: First - are you using the instructions to relay via Postfix, or is CiviCRM's SMTP settings set directly to SES? Second - have you manually checked the bounce account to read the text of the bounce message? – Jon G - Megaphone Tech May 29 '15 at 14:50
  • I have user CiviCRM's SMTP settings set directly to SES, also checked bounce account there is no mails regarding this mailer. If I send the test mailer before mailer campaign getting this error :" Failed to send data [SMTP: Invalid response code received from SMTP server while sending email. This is often caused by a misconfiguration in Outbound Email settings. Please verify the settings at Administer CiviCRM >> Global Settings >> Outbound Email (SMTP). (code: 554, response: Message rejected: Email address is not verified.)] " – Ashwin Jun 1 '15 at 6:43
5

Ashwin - your latest update showing the error reveals the problem. Either a) your SES account is still in sandbox mode, or b) you skipped the steps about verifying your sender address/domain. From my instructions:

  • Log onto AWS, select SES. Note that you only have sandbox access at this time.
  • Click on "SMTP Settings" on the left, record the server info, generate SMTP credentials and record those too.
  • Click on "Verified Senders: Domains". Click "Verify a new Domain". Enter the client's domain name; also click "Generate DKIM settings". Remark: the bounce address must be also verified.

If you've already done this, then request to be moved from sandbox mode into production mode: Instructions here.

  • I'm not in a Amazon SES sandbox mode. Amazon already changed it into production mode as per my request. In Amazon console I can see my domain status verified, DKIM status verified, email address status also showing verified. If it is not verified we can't save SMTP settings in CiviCRM. but I'm able to send personal messages, donation receipts through CiviCRM using this SMTP settings. I'm facing this issue only when I have send the mailer champaign. – Ashwin Jun 2 '15 at 8:35
  • Is it necessary to verify DKIM of email address ? I have verified only DKIM of domain address. – Ashwin Jun 2 '15 at 8:54
  • @Ashwin - Please post screenshots of your AWS confirmed domain page and your bounce processing mail account? That you can send personal e-mails means the domain you're using for your "From" address is verified - but perhaps your bounce processing e-mails are coming from an unverified "From" domain? – Jon G - Megaphone Tech Jun 2 '15 at 17:56
  • 1
    you are right. Bounce mail address also need to be verified. After verifying bounce email address now mails are start sending, previously I have only verified "From" email address. Thanks. – Ashwin Jun 3 '15 at 5:32
1

Silly questions perhaps, but since your outbound email settings in CiviCRM are correct, have you switched on the scheduled job that sends the mailings?

  • 1
    Schedule job is on(Always), cron job is also working properly. – Ashwin May 29 '15 at 9:15
1

Could you try going to your own contact record and sending an email from there to see if the individual mail is being sent properly? Also, since your problem is with the CiviMail campaign, could you go to Mailings > Scheduled and Sent Mailings and report back the status of the mailing that was unsuccessful?

  • I have checked my mailer status, It showing that all mails are bounced, bounce type "Syntax" but I am able to receive individual mail and donation receipt from CRM. – Ashwin May 29 '15 at 13:06
  • As a quick debug approach, try sending a CiviMail to a group of contacts (eg just yourself) with a simple body of just hello and opt-out url, and not header or footer. If that works, try sending content that didn't work. Make sure your header and footer are all valid html, and also the message body. – Joe Murray May 29 '15 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.