2

I run Civi on Drupal. After upgrading from 5.4.0 to 5.10.0, any report I open shows 4 warnings at the top:

Warning: Illegal string offset 'attr' in HTML_QuickForm_advmultiselect->toHtml() (line 807 of /home/tamera/www/dev/sites/all/modules/civicrm/packages/HTML/QuickForm/advmultiselect.php).

Warning: Illegal string offset 'text' in HTML_QuickForm_advmultiselect->toHtml() (line 808 of /home/tamera/www/dev/sites/all/modules/civicrm/packages/HTML/QuickForm/advmultiselect.php).

Warning: Illegal string offset 'attr' in HTML_QuickForm_advmultiselect->toHtml() (line 821 of /home/tamera/www/dev/sites/all/modules/civicrm/packages/HTML/QuickForm/advmultiselect.php).

Warning: Illegal string offset 'text' in HTML_QuickForm_advmultiselect->toHtml() (line 822 of /home/tamera/www/dev/sites/all/modules/civicrm/packages/HTML/QuickForm/advmultiselect.php).

Any ideas?

  • Are these core reports? We have phased out that widget & updated custom fields not to use it - but perhaps some still are in your install – user4278 Feb 12 at 2:54
  • There are all reports that are based on Participants and Contributions. If I now create an identical report from the core templates, then the error disappears. I just wished not needing to create them all over again, but that they could have been somehow migrated during the phasing out. Anyway, thank you, this was valuable. – Elad Feb 12 at 12:51
1

These are fields that have been phased out. Deleting these reports and creating them anew from the core report templates will have solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.