1

Installed Mosaico 2.0-beta4 on Drupal 7.64 and CiviCRM 5.7.2. I followed all installation instructions and installed Shoreditch then Flexmailer then Mosaico.

I'm getting an error - when I try and edit a Mosaico template and drag a block in, it gives the error message of "Sorry an error occurred and your information was not saved".

This happens whether I upload an image into a block, or just drag an empty text box and add dummy text, or anything in between.

enter image description here

This also happens regardless of which base template I'm trying to edit.

If I just try and create a new mail using the base templates, I can't preview the email as HTML or send out a test email (again, regardless of how much or how little I customise the base template) and get the same error message.

I've checked error logs and haven't found anything. All modules and core up to date, any ideas on what I can do to fix this?

Thanks

EDIT: Some of the messages from Browser console. Not sure which of them are relevant:

The resource from “[default]/civicrm/css/?r=f1Bvs” was blocked due to MIME type mismatch (X-Content-Type-Options: nosniff).

.

Error while detaching the browsing context target front: Connection closed, pending request to server1.conn0.parentProcessTarget1, type detach failed

^ That one then has a "Request Stack" of around 20 lines.

Content Security Policy: The page’s settings blocked the loading of a resource at https://raw.githubusercontent.com/favicon.ico (“default-src”).

.

Loading mixed (insecure) display content “http://mosaico.io/srv/f-default/img?method=placeholder&params=166%2C160” on a secure page[Learn More] jquery.min.js:4:19318

unreachable code after return statement

EDIT:

Checked the error log in cpanel, this is an error message we're getting at the same time:

2019-02-27 12:11:55.672900 [INFO] [203.166.241.141:58741-Q:2699717862144599633-5] File not found [/(homedirectory)/public_html/403.shtml] 
  • Have you checked browser console? – Francesc Bassas i Bullich Feb 25 at 8:29
  • @FrancescBassasiBullich I just checked browser console, have added some of the error messages into my post but not sure which one is responsible – josh Feb 26 at 23:27
0

Have you tried asking your web host to see if you're throwing out a server based error, like a ModSecurity issue? I regularly run into those with CiviCRM when I'm doing emails and have to get the server techs to whitelist a process for me so that it doesn't give me an error. Other than a piece of bad formed code (like when someone has copied something from Word or whatever), it's always been this kind of issue for me.

  • Yea, my host was always able to pinpoint things in the logs that I wasn't seeing on my own. It's why now when this issue pops up, they're my first resource and they can quickly whitelist it. – Jenni Simonis Feb 27 at 1:14
  • thanks, I'll see if my host can whitelist whatever needs to be whitelisted. :) – josh Feb 27 at 1:16
  • Cool. I hope that is able to fix it for you. :) – Jenni Simonis Feb 27 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.