1

After completing the payment screen and clicking 'Confirm Contribution' the screen hangs. The button is greyed out but nothing happens. But...if I just hit enter on the screen without first completing anything at all I get an error message about incomplete fields, and then I can complete the screen & proceed normally. But if I first complete all the details and then hit the 'Confirm Contribution' it hangs. I've tried this on Chrome, Firefox and on my Android 8.1 phone - all the same. I am using 5.2 of the Stripe extension, CiviCRM 5.7.3 running under Drupal. Using the second technique described above I've made a couple of payments so there's nothing wrong with the setup, it seems. Update: I have found some errors in the Stripe dashboard, here are screenshotsenter image description here and this enter image description here

  • Did you try 'inspect' in your browser to see if it gives any clues – petednz - fuzion Feb 18 '19 at 18:52
  • I have now done that but frankly wouldn't know what to look for... – Andy Clark Feb 18 '19 at 19:25
  • But I do get a message from Chrome saying 'this page is trying to load scripts from unauthenticated sources' via a little icon at the top of the screen, which appears as soon as the page is loaded. The site has https of course so...?? And yet if I hit enter without entering anything this then allows everything to work after I fill out the missing fields, despite this message – Andy Clark Feb 18 '19 at 20:07
  • Difficult to know what's going on without seeing logs from both ends. You can uncomment this line in the extension on your site to enable debug logging to the browser console: lab.civicrm.org/extensions/stripe/blob/master/js/… But it sounds most likely that you've got some kind of communication issue, or https issue between the the browser and Stripe servers. Have you tried from different networks (eg. corporate networks sometimes do nasty things with https and Stripe might detect that and refuse to work) – Matthew Wire Feb 22 '19 at 23:09
3

The answer is that I had pasted one of the Stripe API keys with a trailing blank, so when I looked at Firefox's web developer console there was a message 'Your key is invalid as it contains whitespace' Working consistently now, but how I previous managed to make a couple of contributions successfully I don't understand!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.