1

I'm running CiviCRM 5.10.3 on the Bitnami WordPress stack (WP has been upgraded to 5.1), and the version of the Bitnami stakc I'm currently on uses PHP 7.0.30, so I'm getting warnings that as of the next release of CiviCRM I'll need PHP 7.1 or higher.

I did a trial run of upgrading the Bitnami stack to their latest which includes MySQL 8.0.13. WordPress works fine after the upgrade, but CiviCRM is throwing SQL syntax errors:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'grouping...

I did disable ONLY_FULL_GROUP_BY (and confirmed it's disabled), so I'm assuming this is an issue with MySQL 8 in general. Is that a reasonable assumption, and if so, is there an ETA on MySQL 8 support? Or are there perhaps other settings changes/workarounds that need to be made for MySQL 8?

I realize this situation is one of the downsides of using the Bitnami stack (i.e. that to get PHP 7.2 I get MySQL 8 along with it), but I do like the convenience of it so I thought I'd ask about MySQL 8 support before exploring other options.

Thanks for any ideas anyone has.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.