2

Civicrm Version 5.4.0

On New Participant Registration, I get an error "Expected one ParticipantPayment but found 0" when I try to register for an event which is not a paid event.

CiviCRM_API3_Exception: "Expected one ParticipantPayment but found 0"

 #0 C:\sites\default\files\civicrm\ext\org.civicrm.multidomaininvoicing\multidomaininvoicing.php(316):
 civicrm_api3("ParticipantPayment", "getvalue", (Array:4))
 #1 C:\sites\all\modules\civicrm\CRM\Utils\Hook.php(274): multidomaininvoicing_civicrm_postProcess("CRM_Event_Form_Participant",
 Object(CRM_Event_Form_Participant))
 #2 C:\sites\all\modules\civicrm\CRM\Utils\Hook\DrupalBase.php(84): CRM_Utils_Hook->runHooks((Array:69), "civicrm_postProcess", 2,
 "CRM_Event_Form_Participant", Object(CRM_Event_Form_Participant),
 NULL, NULL, NULL, NULL)
 #3 C:\sites\all\modules\civicrm\Civi\Core\CiviEventDispatcher.php(90): CRM_Utils_Hook_DrupalBase->invokeViaUF(2,
 "CRM_Event_Form_Participant", Object(CRM_Event_Form_Participant),
 NULL, NULL, NULL, NULL, "civicrm_postProcess")
 #4 [internal function](): Civi\Core\CiviEventDispatcher::delegateToUF(Object(Civi\Core\Event\GenericHookEvent),
 "hook_civicrm_postProcess", Object(Civi\Core\CiviEventDispatcher))
 #5 C:\sites\all\modules\civicrm\vendor\symfony\event-dispatcher\Symfony\Component\EventDispatcher\EventDispatcher.php(164):
 call_user_func((Array:2), Object(Civi\Core\Event\GenericHookEvent),
 "hook_civicrm_postProcess", Object(Civi\Core\CiviEventDispatcher))
 #6 C:\sites\all\modules\civicrm\vendor\symfony\event-dispatcher\Symfony\Component\EventDispatcher\EventDispatcher.php(53): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch((Array:1),
 "hook_civicrm_postProcess", Object(Civi\Core\Event\GenericHookEvent))
 #7 C:\sites\all\modules\civicrm\vendor\symfony\event-dispatcher\Symfony\Component\EventDispatcher\ContainerAwareEventDispatcher.php(167):
 Symfony\Component\EventDispatcher\EventDispatcher->dispatch("hook_civicrm_postProcess",
 Object(Civi\Core\Event\GenericHookEvent))
 #8 C:\sites\all\modules\civicrm\Civi\Core\CiviEventDispatcher.php(47): Symfony\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch("hook_civicrm_postProcess",
 Object(Civi\Core\Event\GenericHookEvent))
 #9 C:\sites\all\modules\civicrm\CRM\Utils\Hook.php(164): Civi\Core\CiviEventDispatcher->dispatch("hook_civicrm_postProcess",
 Object(Civi\Core\Event\GenericHookEvent))
 #10 C:\sites\all\modules\civicrm\CRM\Utils\Hook.php(444): CRM_Utils_Hook->invoke((Array:2), "CRM_Event_Form_Participant",
 Object(CRM_Event_Form_Participant), NULL, NULL, NULL, NULL,
 "civicrm_postProcess")
 #11 C:\sites\all\modules\civicrm\CRM\Core\Form.php(516): CRM_Utils_Hook::postProcess("CRM_Event_Form_Participant",
 Object(CRM_Event_Form_Participant))
 #12 C:\sites\all\modules\civicrm\CRM\Core\Form.php(490): CRM_Core_Form->postProcessHook()
 #13 C:\sites\all\modules\civicrm\CRM\Core\QuickForm\Action\Upload.php(169):
 CRM_Core_Form->mainProcess()
 #14 C:\sites\all\modules\civicrm\CRM\Core\QuickForm\Action\Upload.php(136):
CRM_Core_QuickForm_Action_Upload->realPerform(Object(CRM_Event_Form_Participant),
 "upload")
 #15 C:\sites\all\modules\civicrm\packages\HTML\QuickForm\Controller.php(203):
 CRM_Core_QuickForm_Action_Upload->perform(Object(CRM_Event_Form_Participant),
 "upload")
 #16 C:\sites\all\modules\civicrm\packages\HTML\QuickForm\Page.php(103):
 HTML_QuickForm_Controller->handle(Object(CRM_Event_Form_Participant),
 "upload")
 #17 C:\sites\all\modules\civicrm\CRM\Core\Controller.php(351): HTML_QuickForm_Page->handle("upload")
 #18 C:\sites\all\modules\civicrm\CRM\Event\Page\Tab.php(118): CRM_Core_Controller->run()
 #19 C:\sites\all\modules\civicrm\CRM\Event\Page\Tab.php(175): CRM_Event_Page_Tab->edit()
 #20 C:\sites\all\modules\civicrm\CRM\Core\Invoke.php(309): CRM_Event_Page_Tab->run((Array:3), NULL)
 #21 C:\sites\all\modules\civicrm\CRM\Core\Invoke.php(84): CRM_Core_Invoke::runItem((Array:15))
 #22 C:\sites\all\modules\civicrm\CRM\Core\Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
 #23 C:\sites\all\modules\civicrm\drupal\civicrm.module(445): CRM_Core_Invoke::invoke((Array:3))
 #24 C:\includes\menu.inc(527): civicrm_invoke("participant", "add")
 #25 C:\index.php(22): menu_execute_active_handler()
 #26 {main}

enter image description here

  • Could you please turn on debugging and backtrace in Administer menu » System Settings » Debugging and Error Handling and repeat this? You'll get a much more detailed message, which will help us help you. Also, please copy/paste the text instead of a screenshot? Finally, please edit your question to include the CiviCRM version. – Jon G - Megaphone Tech Feb 24 at 3:27
  • okay @JonG-MegaphoneTech – harshal Feb 24 at 3:52
  • updated @JonG-MegaphoneTech question – harshal Feb 24 at 3:59
3

From the backtrace, you can see that the error is caused by a line in the org.civicrm.multidomaininvoicing extension. I assume this is your extension?

getvalue is only appropriate if you're sure that a value exists; in this case, you made an API call for a value that doesn't exist. If this is a possibility in your scenario, instead use get and search the values array for your result (with error handling to deal with a missing value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.