0

I just updated Civicrm from 5.8 to 5.10.4. I also upgraded Wordpress from 4.x to 5.1. When a user fills out an event registration form and clicks through to the confirm checkout page, the following error is shown at the top of the CiviCRM frame on the Wordpress page:

Warning: Invalid argument supplied for foreach() in /wordpress/path/to/plugins/civicrm/civicrm/CRM/Event/BAO/Event.php on line 1572

Information that is hopefully helpful:

  • Civi 5.10.4
  • Wordpress 5.1
  • Using extension Event Additional Signup to allow users to pay for a membership at the same time as event registration.
  • I am also using these additional extensions: Stripe (payment processor), API v4, CiviDiscount, Mailchimp

The error message has not been helpful in diagnosing the issue and I was not able to find a past solution that helped, although this error has been asked about in several previous posts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.