3

When a user submits a credit card for a recurring contribution, the verification page displays the following message:

I want to contribute this amount every 1 (s)

What do I need to do to replace the value '1' with the text 'month'?

Drupal 7, CiviCRM 4.4, Vanco Payment Processor

  • Sounds like a bug. Which version of CiviCRM? – Coleman May 30 '15 at 21:26
  • 'recur_frequency_units' option group exists and contains the appropriate list of frequencies. – mike_kc May 31 '15 at 3:25
  • 4.4 isn't enough information here - the latest 4.4 point release has changes that are not in earlier versions - so can you specify the exact version. If not the latest point release start by upgrading to it. – eileen May 31 '15 at 5:40
  • 2
    Anyone else parse "every 1 (s)" as "every second"? :) – Chris Burgess Jun 1 '15 at 0:56
2

While it's still clear you've got a bug, I'm pretty sure your issue isn't that you have "1" but rather that the unit--week, month, year--is missing. The numeral is there in case you wanted to donate quarterly--it would say "3 month(s)". Again, not that this makes it any better.

However, it might help you or whoever diagnose the bug. Hopefully it's as simple as the payment processor extension not providing the unit back to the receipt/thank-you page.

2

This was a bug I introduced in an attempt to set is_recur to true, so the checkbox would be checked.

Thank you for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.