2

I very recently upgraded from CiviCRM 5.6.1 to 5.10.4 and WordPress 4.9.9 to 5.1. Since then I get the following Cron error.

Failed loading /usr/local/ioncube/ioncube_loader_lin_7.2.so: /usr/local/ioncube/ioncube_loader_lin_7.2.so: undefined symbol: zend_empty_string

In spite of the error, the CiviCRM scheduled jobs are executed successfully. What is going on? Should I be worried about this? It's annoying to get emails every half-hour about this error.

** Added 3-11-19

Here's my cron code. We use CiviHosting.

/usr/local/bin/php.cli /home/phoenix/www/www/wp-content/plugins/civicrm/civicrm/bin/cli.php -u username -p password -e Job -a execute
1

Were there any php changes as well? I've seen this when there's multiple versions of php installed and cron is using a different one than the web server. Give the full path to php in your cron task for the version you want it to use, and/or check the hosting control panel to make sure php is the one you want.

  • A few months prior to this I changed to PHP 7.2 from version 5. There were no noticeable issues after I made that change. I haven't changed the Cron since setting it up years ago. – George Lozier Mar 11 at 19:52
  • Actually civihosting might have been where I saw it. Open a ticket with them and they should have it resolved pretty quick. – Demerit Mar 11 at 19:59
0

As suggested I opened a ticket with CiviHosting and the fixed it. Here's what they did.

The /home/phoenix/private/CiviCron.sh cron job was configured to work with PHP 5.6, but you have configured the account to use PHP 7.2 as the default PHP interpreter. To fix the cron job, we changed the PHP line in it from php to php7.cli.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.