4

So we are using Drupal 7 and civiCRM 5.10. We want to use this extension https://github.com/civicrm/org.civicrm.contactlayout

We have installed angular profiles (4.7.31-1.1.2) and API v4 (4.3.0) as well as the contact layout (1.3.1). We also have shoreditch.

When we navigate to Administer -> Customize Data and Screens -> Contact Summary Layouts all we get is an empty civicrm screen. When we try to view a profile with these enabled we get the error 'Api ContactLayout get version 4 does not exist.'

Any ideas about this one? I have tried having a search on here and a google of this error message, but so far I haven't seen this issue?

  • There was a discussion in chat.civicrm.org about an update to api4 causing conflicts with contactlayout. Might get the latest info on this by asking in there. – Demerit Mar 13 at 19:29
7

Short answer: you need to update your extensions. Visit your extension admin page and apply all updates.

Longer answer: There are incompatibilities between older and newer versions of the ContactLayout and Api4 extensions. The breaking change was introduced in ContactLayout 1.4 and Api4 4.3 (which were both released on the same day).

Either both extensions need to be at or above those versions, or both need to be below those versions. If one is below and the other is above, things will be broken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.