1

Specific Issue I have a View that contains a Views Block Area as one of its rows. In each of these Views Block Areas I have a Webform that contains a CiviCRM Payment Processor.

I want the Payment Processor that is used to be set on content within the row.

When I set this by Javascript I get a grey box appearing on the screen and disappearing. Google Chrome's Console shows the data is: form?currency=GBP&snippet=4&processor_id=[[index of the selected payment processor]]

My Questions are:

1) What is this for? What does it do? 2) How can I get rid of it / stop it happening? 3) Is there a better way other than javascript to do this? The only other thing I could think of was using views_post_render. That feels like using a sledgehammer to crack a nut.

Purpose I want to be able to have multiple donation options on the same screen for a crowd funding effort. These options are generated by a View. I am open to having a link instead of a payment form, and definitely open to a better way than using Views Block Areas in rows!

  • can you explain a bit more about why you need separate webforms for each payment processor? ie what does this achieve that fails just by offering 'user select' on the PP in a single webform? – petednz - fuzion Mar 14 at 4:55
  • I think you are referring to the jquery blockUI which was enabled on the webform_civicrm payment page recently to prevent submission until the processor has actually loaded all it's fields? – Matthew Wire Mar 14 at 9:54
  • @MatthewWire If you answer the question with that I'll accept it :D – JohnFF Mar 15 at 13:42
1

I think you are referring to the jquery blockUI which was enabled on the webform_civicrm payment page recently to prevent submission until the processor has actually loaded all it's fields?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.