1

By pressing "Print Summary", there are 2 extra blank pages printed. One of them is before the content and the other is after. How can I make them disappear? I'm using CiviCRM version 5.10.4. Thanks.enter image description here

  • At first I was going to blame it on your theme, but I have the same result. It throws an error related to jQuery. I think there may be a bug related to the print summary function. – Sleewok Mar 14 at 15:06
1

There is CSS that is adding the space. When I remove the height for the following it will not print blank pages.

crm-container div.form-item { height: 100%; }

I would create an "extras.css" so that you can override some of the built-in CSS. You can specify a custom CSS file under Administer > System Settings > Resource URLs: Custom CSS URL. Note: the path to the CSS file should be accessible from a web browser.

If you add the following to the extras.css then it will fix the print of extra pages:

#Print1 div.form-item {
    height: 0;
}

When you go to print summary you can cancel the chrome printing pop-up and then inspect the CiviCRM page (it has the "print" and "done" buttons). You can further refine the print style using the Chrome Dev tools.

  • Thanks very much, it works. However it changes other pages style. – Joshua Mar 15 at 11:29
  • Interesting. I thought the id #Print1 was unique to the print page, which should make it only impact print pages. You may need to target the CSS a little bit more if this is not the case with your theme. Trying using this instead: form#Print1>div.form-item { height: 0; } – Sleewok Mar 15 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.