2

In a video from 2017, CiviAccounts and the accruals accounting feature/deferred revenue are explained quite well: https://www.youtube.com/watch?v=bNIHXBA6EEg (starting from minute 39). According to the video, the feature was supposed to be new in 2017. What it does is, instead of creating one transaction for an annual membership, it should basically break it up into twelve monthly transactions.

In a test installation, I am now trying to set this up. I.e. when someone purchases an annual membership on July 1, half of the revenue shall be recognized within the current year, the other half in the following year.

Although I enabled the check box in the settings of CiviContribute ('Enable Deferred Revenue') and set up the deferred revenue account under the financial type 'Member Dues', I absolutely cannot get this feature to work. - According to the video, nothing else needs to be done.

Unfortunately, I cannot find anything about this in the User Guide or in the System Administrator Guide. Also google reveals only very little information, e.g. 'CRM-16189 Deferred Revenue Support', but this did not really help me in configuring my system.

This leads me to two questions:

  1. Does this feature actually exist or has it never been completed or removed?
  2. Am I missing any obvious or hidden settings that I need to tweak in order to make deferred revenue work?

Any help is much appreciated!

Edit: I am using CiviCRM 5.11.0 with Wordpress

  • 1
    This doesn't answer your question but may be an alternative if your aim is have monthly payments for an annual membership: github.com/compucorp/uk.co.compucorp.membershipextras – Aidan Mar 18 at 13:05
  • Thanks @Aidan for pointing me to this extension - I will definitely look into it. In particular, the membership period feature to have more specific information per membership contribution seems interesting. However, for accounting reasons I still need to sort this deferred revenue issue out first, since most memberships will be based on one single annual payment. – Joachim Mar 19 at 10:50
1

There is probably a bug in storing the settings for this option, which prevents it from having any effect. See also here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.