3

We have a rolling, one year membership set up and users can renew it manually. We do not have auto-renew set up and until we started hearing about this issue, didn't even know how to set up a "lifetime" membership. The membership gives them special member-only access to the site using the Drupal CiviMember role sync module once the membership status is "complete".

What happens is that a user goes to subscribe (and possibly renew) and will occasionally get a message on the contribution form that says, "You have a current lifetime membership which does not have to be renewed." On problem with this is that they don't have access to the member area until an admin goes in and subscribes them manually.

What could be causing this? The first time it was reported was a couple versions ago but we're on CiviCRM 5.10.4 and Drupal 7.64. I haven't been able to collect enough scenarios to determine if it's new users only or not.

enter image description here enter image description here enter image description here enter image description here

There is also a price set for the fee and we have coupon codes.

Edit: I performed a search using search builder and discovered that 2,876 (roughly one third) who are members have no defined membership start date. I believe this issue is a residual affect of a previous issue. The search was for all contacts who have the membership but the start date is null. Only 167 however, had no end date. 2,880 Have no "member since" date.

  • Do you have any lifetime membership types configured? If so, do they have any members? Do those provide any membership by relationship? – Aidan Mar 19 at 11:15
  • Go to Administer > CiviMember > Membership Types for an overview of the types including duration and related memberships – Aidan Mar 19 at 12:28
  • It's the only one. I added a screenshot of that also. – Christia Mar 19 at 17:46
  • Ok, so it's not getting confused by 'real' lifetime memberships. Is that error message exact? I can't find it in a quick grep through the code. Do you have any custom code/extensions/overrides that might be causing this? Are users renewing via contribution page or webform? – Aidan Mar 19 at 18:07
  • Via a contribution form. No custom code that I'm aware of. The message is exact. When I inherited the project years ago there may have been some but I've reworked it completely since then and they didn't have any memberships set up yet or used yet. – Christia Mar 19 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.