2

So I'm having a weird issue where when trying to create a new mailing or event. The wysiwyg editor does not show up, instead the html editor appears as blank. There are errors in console (404 errors) where the page is trying to load ckeditor/skins/moono/skin.js. However, it is trying to load it from the web root via the Drupal core.(['web_root']core/assets/vendor/ckeditor/skins/moono/skin.js)

This is the same with other assets like the editor.css file.

Naturally these assets do not exist in the Drupal core ck-editor directory. Is there a way to direct these to the Civi resources (that do exist) or fix these error.

I ran into this after fixing the Error name not resolved error with crm.ckeditor.js. I followed the guide steps in this Civi stack exchange here.

crm.ckeditor.js not found

This allowed for the crm.ckeditor.js script to be found, but now it cannot find the aforementioned assets. Which previously were not being loaded or called.

1

I also had this problem. It happened ~95% of the time but not 100% of the time, leading me to believe there's a race condition present. It started when I upgraded from Civi 5.12.1 to 5.12.3, but you experienced this problem sooner and I'm guessing it's tied to Drupal 8.6.15. It also happened on my test site but not my dev site (haven't pushed to the live site yet for obvious reasons).

I was able to solve it by uninstalling/reinstalling the core ckeditor module via drush. However, I'm not sure why that fixes it, but I've been unable to trip the issue. In my debugging, it certainly seems that Civi's CKEditor is loading the paths of the Drupal CKEditor. I'm not sure why though.

0

Part of the install process for drupal 8 currently involves copying some things to the libraries folder. If you used the composer method (https://gitlab.com/roundearth/drupal-civicrm-project) it gets handled mostly automatically, but you might still need to set some settings in civicrm.settings.php. See https://hq.megaphonetech.com/projects/commons/wiki/CiviCRM_for_Drupal_8_installation_notes

  • Our Organization did not use the round-earth installation, I can check with a colleague who set it up on how exactly he set it up. However, At present the components it is trying to call from the Drupal core are located in web/libraries/civicrm/bower_components/ckeditor. I tried to make the changes to the civicrm.settings.php file in the link you provided, but this caused other components to not be found. – Sophia_Connell_NFB Mar 22 at 20:13
  • It sounds like it might be a composer-based install, so maybe all you need to do is copy the other components. The old manual method had a script at lab.civicrm.org/dev/drupal/issues/9 which should still work to copy the other components to libraries, just maybe make a backup of libraries/civicrm in case something gets overwritten you don't want overwritten. – Demerit Mar 22 at 20:27
  • I ran the script in the link your provided and set the web root to {cms.root]/libraries/civicrm. To no avail Civi still tires to access components from cms.rootcore/assets/vendor/ckeditor/skins/moono/editor.css, cms.root/core/assets/vendor/ckeditor/styles.js" and cms.root/core/assets/vendor/ckeditor/skins/moono/editor.css – Sophia_Connell_NFB Mar 26 at 14:47
  • If you go to admin - system settings - directories, then click the blue question mark icon in the green description area at the top it will display what it thinks you have. That might provide a hint. – Demerit Mar 26 at 16:18
  • My cms root looks fine, to confirm my civiroot should look like this? [civicrm.root] web.root/vendor/civicrm/civicrm-core – Sophia_Connell_NFB Mar 26 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.