1

Using CiviCRM 5.10.4 with Drupal 7.64.

Trying to use a checksum link in an email being sent out to a group, for them to submit a profile which has been pre-filled in with their details.

My link is below:

DOMAIN.com/civicrm/profile/edit?gid=23&reset=1&id={contact.contact_id}&{contact.checksum}

The link works perfectly in incognito on desktop, and when copying the link into a mobile web browser. However, when opening the test email on a mobile mail app (e.g. Mail on iOS)... clicking the link doesn't open anything. When I long-press the link I can see the full URL is there and I can copy the link into a browser, but actually clicking the link doesn't take me to my mobile web browser or trigger any action on my phone. Have tested this on multiple devices, though only iPhones.

Bit of a strange question I know, but does anyone know what I might be able to do to fix this? Annoying that it works everywhere except where the majority of our users check their email.

  • Do you have http:// or https:// before the link in the email? If not, try adding it. – Demerit Mar 22 at 1:48
  • @Demerit such a simple solution hahaha thank you! Add it as an answer so I can accept it :) – josh Mar 22 at 2:58
  • Great! . . . . . – Demerit Mar 22 at 3:06
0

Do you have http:// or https:// before the link in the email? If not, try adding it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.