2

I'm running CiviCRM 5.11.0 in Wordpress 5.1.1. Currently, I'm not able to renew any membership in CiviCRM: Membership section of the selected profile > Renew membership. When I confirm renewal, the system gets stuck in saving screen forever and nothing is registered on the database.

I tested the renewal using a profile page in the frontend, for myself, and it worked. It's only in the backoffice (where I register 99% of membership renewals) where this happens. Contributions are working fine, it's not an issue of recording payment or the associated contribution.

Do you know what may be causing this issue and how to solve it?

Cheers João

  • In order to rule out the obvious, have you cleared the CiviCRM caches and temp files? Has it been doing this since upgrading to 5.11.0? – Christia Mar 24 at 11:48
  • Hi Christia Yes, all cleared. I upgraded yesterday to 5.11.0 but the behavior was already there before the upgrade, so it's not related to that. – João Mar 24 at 12:17
  • when you renew via backend does it use a pop up screen and if so, have you tried right-clicking and opening in a new tab? Sometimes doing so will show the error msg which you won't see via the pop up – petednz - fuzion Mar 24 at 20:06
  • Yes, it pops up the renewal screen. I just opened it in a new tab and when I click on save I see the default not found error for my domain (no civicrm related stuff). – João Mar 25 at 18:48
  • So I'm able to create a new membership in the backend, it's only when changing an existing membership that this occurs (ammend a date, renew, etc) – João Mar 27 at 20:57
2

It reminds me of a similar issue I had at a client last week: we received a 403 error when we tried to edit memberships.

The error was due to an anti sql-injection mechanism that was in place at the hosting provider. It could be turned off via the control panel.

Can you check if something similar is active in your installation? Either in the control panel or via a Wordpress security plugin? Ultimately, ask the hosting provider.

  • Hi Alain. I will ask the hosting provider, thanks. – João Mar 29 at 8:18
  • This solved the issue, my provider shut down an injection and is now working. Thanks to you all. – João Mar 29 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.