8

We've updated CiviCRM to 4.6.3. Since then, CiviMail has stopped working. When we log in, the following warning pops up:

"Warning: Outbound email is disabled in system settings. Proper settings should be enabled on production servers."

We set it up correctly in Email settings both mail() and SMTP, and in both cases the test mail is sent OK according to the popup window (view attached file). But it does not get delivered so we believe it isn´t really sent.

We´ve checked if we've been blacklisted or anything but we haven't.

Afterwards, we've tried writting random letters and numbers in SMTP server and SMTP user, and the popup stills says that the mail has been sent.

We would appreciate any help to find a solution.

Thank you!!

enter image description here enter image description here

8

It may be that you have set your email to go to a file. Check your civicrm.settings.php (mine's in sites/default under the Drupal root).

Look for the lines referring to CIVICRM_MAIL_LOG and make sure the define statement is commented out.

The comment on CIVICRM_MAIL_LOG says ...

This setting logs all emails to a file. Useful for debugging any mail (or civimail) issues. Enabling this setting will not send any email, ensure this is commented out in production. The CIVICRM_MAIL_LOG is a debug option which disables MTA (mail transport agent) interaction. You must disable CIVICRM_MAIL_LOG before CiviCRM will talk to your MTA.

  • This is almost certainly correct. The code is at CRM/Utils/Check/Env.php line 110, and there are four possible settings that could cause their warning. Your screenshot eliminates the other three. – Jon G - Megaphone Tech Jun 1 '15 at 13:20
  • Thank you very much. We've tried commenting out that line of code, but no change at all. //define( 'CIVICRM_MAIL_LOG', '/home/mpdlinfotg/www/sites/default/files/civicrm/templates_c/mail.log' ); We've checked www/sites/default/files/civicrm/templates_c/mail.log and every attempt is recorded, but no email is delivered. – MPDL Jun 1 '15 at 13:48
  • If mails are being written into mail.log, then something is defining CIVICRM_MAIL_LOG. Grep for it and comment it out. – Ken West Jun 1 '15 at 14:07
  • You were right. We were uploading the updated civicrm.settings.php file through filezilla but because of the permissions it was not updating in the server, and we didn't notice it. Now it's working perfectly. Againg, thank you very much for your help. – MPDL Jun 1 '15 at 15:13
  • Is this coming from a code update? It seems strange that code sets this, but the System Status points you to the email settings where there is no indication of this being a possible reason. – thoni56 Aug 23 '18 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.